Space Shooter Bugs

Report any problems that may have occurred while using 001 Game Creator.
Forum rules
Make sure you are using the newest version. This can be downloaded at the top of the site via the "downloads" link.

Subscript out of range error 9: This is a generic error, and we'll need way more information than that to figure out the problem. If you get this, strongly consider following the instructions of submitting your project through the Submit Bug feature within the editor.
User avatar
epsilon017
001 Subscriber
 
Joined: Sun Jul 06, 2008 9:14 pm
Location: USA

Space Shooter Bugs

Postby epsilon017 » Sun Jan 01, 2017 2:20 pm

As I was playing with the Space Shooter demo, I noticed an instance would come up where the sprite for the laser beam would stop appearing while firing it. Even more so however, is that the enemies will start to get stuck on the other end of the screen.

At the same time, one of my projects (Coincidentally, a space shooter), has also been showing problems regarding actor movement, including the inability to move the player's ship.

I've been trying to see if I can diagnose what could be causing this, but so far I'm not sure. I'm making this post so others can be aware.
Defenders of Sol (Demo): http://engine001.com/games/Defenders%20of%20Sol_3083.htm

I really have no idea what I'm doing.

User avatar
Mike
001 Co-Founder
 
Joined: Sun May 08, 2005 1:29 pm
Location: Ontario, Canada

Re: Space Shooter Bugs

Postby Mike » Sun Jan 01, 2017 2:25 pm

I'm currently extremely busy, so I'd love some help in someone from out community in fixing this. If there's an actual bug, it'd help to get a test project showing it specifically, or some clear steps - it's just hard to reproduce things overall with the space shooter demo in general because the powerups are random.

User avatar
Lee
001 Support
 
Joined: Thu Sep 21, 2006 1:59 pm
Location: United Kingdom

Re: Space Shooter Bugs

Postby Lee » Mon Jan 02, 2017 5:55 am

The player ship issue sounds familiar to an issue Wonderland reported. In that instance, it was the collision box that was having issues but I wasn't able to reproduce the problem in the Space Shooter demo itself (only his specific project). For context: both projects were using the "Player Ship" sprite, which has polygonal collision.
Lee - 001 Project & Community Manager
DOWNLOAD DEFLECT | Vote on Steam Greenlight HERE!

User avatar
Wonderland
001 Support
 
Joined: Tue Dec 21, 2010 4:18 pm
Location: Canada

Re: Space Shooter Bugs

Postby Wonderland » Mon Jan 02, 2017 7:50 am

Reimporting the sprite from the space shooter demo to my game again did not help. The only thing that did was removing polygonal collision from the sprite and replacing it with the old box-style collision.
Last edited by Wonderland on Mon Jan 02, 2017 7:50 am, edited 1 time in total.
Reason: Automatically merged double post.

User avatar
epsilon017
001 Subscriber
 
Joined: Sun Jul 06, 2008 9:14 pm
Location: USA

Re: Space Shooter Bugs

Postby epsilon017 » Sat Jan 07, 2017 8:05 pm

Okay, after testing out 001's Space Shooter demo, as well as my own space shooter, I have found that unchecking the "ceiling" boundary in the map properties has solved the problem I've been having.

Still not sure what the core issue is though, as this wasn't necessary before.
Defenders of Sol (Demo): http://engine001.com/games/Defenders%20of%20Sol_3083.htm

I really have no idea what I'm doing.

User avatar
Mike
001 Co-Founder
 
Joined: Sun May 08, 2005 1:29 pm
Location: Ontario, Canada

Re: Space Shooter Bugs

Postby Mike » Mon Jan 09, 2017 7:54 am

Could you possibly revert that ceiling change and see if changing collision to box or sphere works better over polygon? I believe it's a specific polygon collision optimization that is failing and I can just swap it out if it's the case.


Return to Bug and Error Reporting

Who is online

Users browsing this forum: No registered users